Instalar Firefox 3.5.x pre y 3.6a pre en Ubuntu 9.04

Publicado: julio 14, 2009 en Firefox, Ubuntu
Etiquetas:, ,

Actualización: Ubuntu en estos momentos ya ha puesto a disposición Mozilla Firefox 3.5.x en los repositorios oficiales para la versión 9.10 Karmic Koala. Si abréis Synaptic lo distinguiréis porque porta el logo oficial de Ubuntu, ya que el soporte previsiblemente termine en enero para Firefox 3.0.x. Así que esta guía solo la aconsejo para la instalación de Firefox 3.6 Namoroka.

Para los que añadistéis firefox 3.5 usando esta guía, sin importar el perfil de Firefox 3.0.x, este se encuentra en la ruta /home/[usuario]/.mozilla/firefox/firefox/firefox.3.0-replaced

Así que tan solo debéis renombrar el archivo firefox.3.0-replaced que se encuentra en la misma carpeta por el archivo xxxxx.default que ha creado esta nueva versión. De esta manera importaréis los marcadores, historial, extensiones, cookies y demás datos a Firefox 3.5 Shiretoko.

Si estás interesado en ver cómo son estas dos versiones de desarrollo, tanto la versión 3.5.x pre,  como la  3.6 beta2 pre  “Namoroka”  en Ubuntu. Sigue estos  sencillos pasos.

Primero agregamos los repositorios desde la terminal, si tenéis otra versión que no sea la 9.04, sustituid jaunty por la que corresponda p.e karmic.

sudo sh -c "echo 'deb http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu jaunty main' >> /etc/apt/sources.list"
sudo sh -c "echo 'deb-src http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu jaunty main' >> /etc/apt/sources.list"

Añadimos la clave de la llave.
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 247510BE
Actualizamos los repositorios:

sudo apt-get update

Instalamos la versión 3.5.

sudo apt-get install firefox-3.5

Actualización por el idioma.  Si os aparece en inglés podéis añadir el xpi de idioma correspondiente a vuestra demarcación:

Español de España (es-ES).

Español de Argentina (es-AR).

Español de México (es-MX).

Español de Chile (es-Cl).

Si no queréis descargar los archivos xpi de este blog,  podéis descargarlos desde el ftp oficial de Mozilla.

Una vez tengáis instalado Firefox 3.5.x ya podéis desistalar el paquete Firefox 3.0-branding en el menú Sistema–> Adminsitración–> Synaptic–> clic derecho sobre ese paquete–> Marcar para desistalar y os lo desistalará con el resto de dependencias, manteniendo los datos de buestro perfil como son marcadores, complementos, contraseñas, historial etc.

O si lo preferimos también podemos instalar la versión  de Firefox 3.6. alpha Es una versión en teoría mucho más inestable que la anterior, ya que en estos momentos, no llega a ser ni alpha.

sudo apt-get install firefox-3.6

Si has instalado esta versión puedes bajarte el xpi de idioma (se instalará como una extensión) de estos enlaces:

es-ES (español de España).

es-AR (español de Argentina).

es-MX (español de México).

es-CL (español de Chile).

Enlace al sitio oficial con todos los xpi de idioma disponibles para esta versión (por si no aceptáis la descarga desde este blog).

Conforme se vayan actualizando los repositorios,  encontraremos versiones más adelantadas, ya que este repositorio está enfocado principalmente a desarrolladores y probadores.

Si ya anteriormente instalastéis Firefox 3.5 beta, estos dos navegadores tomarán los mismos archivos del perfil para si, aunque conforme hagamos uso de una y otra versión,  lógicamente se modificarán de forma independiente,  ya que cada navegador ya dispone de su propio perfil.

A mi particularmente después de instalar la versión 3.5 después de la 3.6, me ha fallado el plugin de flash player, pero lo he resuelto creando un nuevo perfil. Para ello he pulsado el atajo Alt+F2, he escrito firefox-3.5 -profilemanager –> botón “Create profile”  y he creado un nuevo perfil de uso, dejando inactivo al perfil “default”.

Anuncios
comentarios
  1. Nico dice:

    Muy buena info, enviada a Twitter.

    Saludos ^^

  2. […] 3.5.1 en Ubuntu y en español. 19 07 2009 Si seguisteis los pasos para tener Firefox 3.5 en Ubuntu, os aparecerá el mensaje que no es compatible vuestro paquete de idioma 3.0.7 con la versión de […]

  3. Alberto dice:

    Quiero conservar firefox 3.0.1.1 a la vez que el 3.5 y el mismo 3.5 en alpha a la vez que el 3.6. Hay problemas de conflictividad entre versiones?

  4. noctuido dice:

    Hola Alberto.

    No no hay ningún problema, de la forma que describo en la instalación los tres (el Firefox 3.0.11, Firefox 3.5.1 y Firefox 3.6a1pre) conviven y se mantienen perfectamente, empezando porque los tres tienen cada uno su propio perfil.

    El único problema que he visto es el del fallo del flash plugin, el cual he dicho cómo resolverlo en el último párrafo.

    Saludos. 🙂

  5. Oso429 dice:

    Gracias por la ayuda

  6. niko dice:

    gracias por la ayuda
    excelente aporte

  7. Chencho dice:

    buenas.

    Tengo un problema con el 3.6

    Se instaló bien, pero tras una actualización del sistema (apt-get upgrade) no se ve ni la barra de estado, ni la dirección de las webs, se abre una página en blanco en lugar del inicio, … en fin, un pequeño desastre.

    He intentado desinstalar con purge y volver a instalarlo, pero no hay forma de que funcione correctamente otra vez.

    Ahora mismo estoy escribiendo desde él, pero es muy molesto no ver las urls de las webs que visito ni el estado.

  8. noctuido dice:

    @ Chencho ¿Estás en Ubuntu Karmic Koala 9.10? Lo digo porque en esa versión está dando problemas Firefox con AppArmor. No sé tal vez lo hayas activado, aquí tienes la solución si es tu caso: http://aldeby.org/blog/index.php/firefox-interface-not-loading-properly.html (en) y no es otra que desactivarlo.

    Puede ser también por culpa de alguna extensión o el perfil se haya estropeado.
    Para averiguarlo, cierra completamente Firefox, pulsa el atajo de teclado Alt+F2 y pones firefox -safe-mode y deshabilita los complementos/agregados/extensiones y mira a ver si te aparece igual.

    Con lo que te pase me lo comentas, o si no me has entendido. 😉

    Saludos. 🙂

  9. Chencho dice:

    Solucionado.

    He tenido que borrar la garpeta .mozilla de la carpeta usuario y reinstalar.

    Sin embargo, el idioma español de españa se descarga desde:

    http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009-09-21-05-mozilla-1.9.2-l10n/firefox-3.6a2pre.es-ES.langpack.xpi

  10. noctuido dice:

    @Chencho Era la solución más drástica la que has usado, que es la de eliminar completamente el perfil y los perfiles que tuvieses dentro. Ten en cuenta que dentro de la carpeta /.mozilla estarían los perfiles de thunderbird, sunbird, songbird y otros programas de mozilla si los tuvieses instalados.

    Los perfiles van aparte de las instalaciones/desistalaciones de paquetes o programas que hayas instalado en linux. Por eso por mucho que desistales, la información de cookies, marcadores, contraseñas, historial etc. persiste a no ser que como has hecho tú, borres el perfil.

    Sobre el xpi de idioma, pues sí, debo actualizarlo, lo que pasa es que no saco ni tiempo 😦 ya que la noticia la publiqué con una versión anterior, y por tanto con un xpi de idioma de una versión anterior a la que comentas, que ya es la previa a la alpha 2.

    Saludos. 🙂

  11. noctuido dice:

    @oso429 y @Nico

    De nada. 🙂

  12. shakaran dice:

    Por alguna extraña razon (debe ser algun bug) cuando instalas cualquier plugin (idioma u otro) te dice que reinicies, pero al reiniciar firefox, sigue diciendo de reiniciar y ya no coge el plugin. Si le das a cancel upgrade, se queda el plugin, pero claro ya no puedes actualizarlo. No se si es porque haya algun conflicto de perfiles o algo similar ya que tengo la version 3.0, 3.5 y 3.6 instaladas.

    Con ese follon llevo sin poder instalar la versión de idioma de firefox desde que salio la 3.5 y no hay donde digan algo al respecto.

  13. noctuido dice:

    @shakaran. Bienvenido a mi blog. 🙂

    Ya acabo de actualizar los archivos xpi de idioma, para instalar en la última versión que han puesto en los repositorios, que es la 3.6 beta1 pre. Así que debes descargarte el archivo que corresponda a tu zona, ya que en cada actualización hay que añadir el xpi, hasta que en los repositorios añadan paquetes de idioma (no sé si lo harán).

    Modificaría el xpi de idioma para que fuese compatible con todas las versiones que vayan sacando hasta que llegue la final 3.6, pero eso podría implicar que acometieran cambios y no funcionase correctamente el xpi de idioma.

    ¿A qué plugins te refieres? Si es al idioma ya te he explicado lo que hay, si es alguna extensión lógicamente el desarrollador debe adaptarla a la nueva versión también, y si no te lo marca como incompatible.

    Puedes modificar la numeración para que los archivos xpi te sean compatibles (si quieres) tal y como expliqué en esta entrada.

    Saludos. 🙂

  14. shakaran dice:

    @noctuido: parece ser que es un bug, ya que aunque descargue el .xpi de mi zona y versión sigue pidiendo reiniciar. Los plugins son muchos los que tienen el mismo comportamiento (Gmail Manager, AdBlock, etc) luego debe ser algo de firefox, no es problema de la versión del .xpi con firefox, ni compatibilidad, es que no llegan a instalarse del todo y siempre pide de reiniciar para que hagan efecto los cambios.

  15. noctuido dice:

    @shakaran. En el estado que estás tomaría el “camino del medio”, quitar los repositorios que has añadido con
    sudo gedit /etc/apt/sourcest.list
    borrarlos con el cursor, guardar los cambios y añadir IceCat que para el caso es una copia de Firefox. Para activar el plugin de flash en IceCat entra en el menú Herramientas—>Complementos–>Plugins—> Flash–> botón activar.

    Debes tener alguna configuración modificada al resto, porque este post lo ha tenido miles de visitas, además que he indicado los pasos que yo he hecho en mi Ubuntu y solo se ha comentado tu caso, cosa que te agradezco, porque me sabría mal que hubiese cometido un error y el último en enterarse fuese yo 😉 . Te aconsejo si tienes tiempo e interés procedas a hacer la detección básica de problemas http://www.mozilla-hispano.org/documentacion/Detecci%C3%B3n_b%C3%A1sica_de_problemas

  16. shakaran dice:

    @noctuido: quiero mantener el repositorio y seguir usando firefox (original). El problema no es con el plugin de Flash (si no con todos los que se actualicen o instalen nuevos).

    Que el post tenga miles de visitas, no indica que a todo el mundo le haya salido bien. Incluso puede que si hay error no sea por tus pasos (sino por alguna cuestión de firefox).

    Parece que no soy el único con este problema ya que hay un bug reportado en launchpad (quizas cuando alguien se queja aparecen otros con mismos síntomas que lo desconocían o no lo habían advertido): https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/441860

    No he probado a crear un perfil nuevo, porque en principio no tengo porque y debería arreglarse. Si ya veo que sigue esto sin más solución, haré una copia de marcadores y configuraciones y probaré de nuevo con otro perfil.

  17. noctuido dice:

    @shakaran gracias por el apunte. He visto que el reporte de bugs es para Ubuntu 9.10, la cual también daba problemas con AppArmor como mencioné en otro comentario.

    Lo realmente raro es que a mi me han venido funcionando perfectamente tanto Firefox 3.5.4 pre, como Firefox 3.6b1 pre en Ubuntu 9.04, incluyendo los paquetes xpi de idioma es-ES en cada versión, con la salvedad de que eliminé Firefox 3.0.x porque no tenía interés en usarlo.

    Lo de las miles de visitas, lo dije para agradecer tu comentario, no para contrarestar tu problema con un dato estadístico baladí. 😉

    Saludos. 🙂

  18. shakaran dice:

    @noctuido: quizás hayas dado en el clavo y sea por apparmor y justamente para 9.10, esperemos a ver que pasa con la resolución del bug y si esta para la 9.10 Final arreglado.

    Saludos

  19. […] en | Noctucido ¡Comparte este articulo! Twitter Digg Facebook Delicious StumbleUpon Google Bookmarks […]

  20. […] Instalar Firefox 3.5.x pre y 3.6a pre en Ubuntu 9.04. PHP Error Message Fatal error: Call to undefined function wp_related_posts() in /home/a4509430/public_html/wp-content/themes/UbuntuWP/single.php on line 15 Free Web Hosting […]

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s